Microsoft Edge and Paid YouTube Content

This evening I decided I wanted to watch some YouTube content on my PC using Microsoft Edge. I have a decent list of purchased movies and TV series through the Google Play Store. After looking over the list of paid content I settled on a movie and I clicked on it ready to watch on my second monitor while I was doing some other stuff on my primary monitor. To my surprise I was greeted by a playback error. To be exact I got the following error message in the video player (I have blacked out some content that I deem not relevant).

YouTube Paid Content Playback Error

The exact message reads, “An error occurred. Please try again later. (Playback ID: MLeXgYpv05LH1Uhq)“.

I decided to click the “Learn More” link which would hopefully provide some informative information as to why I got this error. But in typical Google fashion I have found it was little to no use. I decided to try their troubleshooting steps.

YouTube Paid Content Playback Error Troubleshooting Page

I first closed every tab that I had open except the YouTube tab and tried again. No luck got the same error message, a different Playback ID error code was presented though. The next step was to restart my router, did that and still no luck. I restarted my computer to see if that would help like it said, again the same error message. The second last option was to verify that I was using the latest version of my browser; there was no Windows updates and I am unaware of any other way to update Microsoft Edge (if there is please let me know). The absolute last resort is to use Google Chrome. I’m sorry Google but this isn’t going to happen and really is not a troubleshooting step.

Curiously I decided to try some videos from some of my subscribers and those videos played absolutely fine with no issue on Microsoft Edge. In fact I am watching one of my favourite YouTubers playing XCOM 2: War of the Chosen as I write this. So clearly there appears to be an issue trying to stream paid content through YouTube on Microsoft Edge. I quickly tried my Android phone and using the official YouTube app I had no issue playing the same video (so it was not a licensing issue) and the video plays absolutely fine on my Xbox One X using the YouTube app.

Finally I decide to try Google Chrome. Low and behold the video starts with no issue. I tried again on Microsoft Edge and I get an error message. To me it seems that Google is doing something in back that is restricting content being played on Microsoft Edge or Microsoft has something in Edge that Google does not like, blocking paid content from being played. Perhaps being paid and licensed content I thought maybe there was a setting that was causing issues, but Netflix on Microsoft Edge had no issues playing. Has anyone else had the same issue? If so did you get it resolved or does the problem persist? Generally I have found Google to be near useless when it comes to any support and their response to issues is down right abysmal (the only other company to be close or worse is Valve and Steam Support). Looks like when I am on my PC or laptop I won’t be streaming any paid content from YouTube until this is fixed.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s